Can't compile

Home Forums OWL OwlWare Can't compile

This topic contains 24 replies, has 3 voices, and was last updated by  JoseFuzzNo 2 years, 1 month ago.

Viewing 10 posts - 16 through 25 (of 25 total)
  • Author
  • #2542


    OK, that would help me a lot…how long will it take you to update?

    And, details on your set-up please, so i can use it as well for my Owl experiments…I don’t want to use Windows anymore!





    Well, I did get it compiled…but…

    -I did comment out the jot reverb.
    -I think the change I made to the biquad filter file (see above in the last few replies by me)- copied it with the additional extesion, so I have a biquad .h and .hpp…, as I discussed due to errors I was getting…

    Not sure if that was a good idea!

    Also, it compiled as above with the warning shown in my earlier post.

    Anyway, downloaded to the OWL and that was OK, was successful.

    If I use the FreeVerb program, shows CPU load at some very high number, I think it was 168%, and, audio is very bad, of course…

    This problem exists on every more complex file, some simple patches are OK.

    So, I assume this is due to the warning I had earlier and maybe my change to the biquad extension?

    If I re-load your V12 file, all is OK…




    See last post, and re-compiled and here is the error:

    gh@gh-HP /cygdrive/c/users/gh/desktop/owlware/owlware
    $ make bin
    In file included from ./Libraries/OwlPatches/LpfDelayPatch.hpp:34:0,
    from ./Source/factory.h:15,
    from ./Source/FactoryPatches.cpp:32:
    ./Libraries/OwlPatches/CircularBuffer.hpp: In member function ‘void CircularBuffer::write(float)’:
    ./Libraries/OwlPatches/CircularBuffer.hpp:18:21: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
    if(++writeIndex == buffer.getSize())
    Successfully built OWL Pedal Debug firmware in ./Build/OwlWare.bin


    Martin Klang

    By default the build compiles a debug version, which runs at apprx twice the CPU load. Recompile with make CONFIG=Release clean all. Also, by default it compiles for the OWL Pedal, add PLATFORM=Modular for OWL Modular hardware configuration. (I’ll add that to the readme)

    The CircularBuffer issue is just a warning, as you can see at the end Successfully built... it still compiles.


    Martin Klang

    I’m developing on Ubuntu and Debian Linux, which works very well and is easy to set up as a VM using VirtualBox or VMWare. No crazy driver problems like on Windows!



    Hi Martin:

    Thanks for all the great help as I learn this!

    You mentioned you need to update Owlware- any idea when this might occur as I am very interested in more complex reverb, such as the JOT reverb.

    When I load to the Owl, here is what I get and is this normal, or? :

    gh@gh-HP /cygdrive/c/users/gh/desktop/owlware/owlware
    $ make dfu
    ./Tools/dfu-util/dfu-util -d 0483:df11 -c 1 -i 0 -a 0 -s 0x8008000:leave -D ./Bu ild/OwlWare.bin
    dfu-util 0.9

    Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
    Copyright 2010-2016 Tormod Volden and Stefan Schmidt
    This program is Free Software and has ABSOLUTELY NO WARRANTY
    Please report bugs to

    Opening DFU capable USB device…
    ID 0483:df11
    Run-time device DFU version 011a
    Claiming USB DFU Interface…
    Setting Alternate Setting #0 …
    Determining device status: state = dfuERROR, status = 10
    dfuERROR, clearing status
    Determining device status: state = dfuIDLE, status = 0
    dfuIDLE, continuing
    DFU mode device DFU version 011a
    Device returned transfer size 2048
    DfuSe interface name: “Internal Flash ”
    Downloading to address = 0x08008000, size = 262120
    Download [=========================] 100% 262120 bytes
    Download done.
    File downloaded successfully
    Transitioning to dfuMANIFEST state
    Invalid DFU suffix signature
    A valid DFU suffix will be required in a future dfu-util release!!!
    Uploaded ./Build/OwlWare.bin to OWL firmware



    Hi again:

    See my reply, above and:

    I have read about CPU time…I see Freeverb using 89% and memory use @ 50644 (this according to OwlControl).

    I saw on a forum post that Freeverb should occupy 18% ? I wonder what I am doing wrong?





    You probably need to do make CONFIG=Release dfu. Make sure that you clean the object files before with make clean




    Thank you for the kind help…still very new at all of this!

    Were you responding to my comment about the CPU time or the earlier one regarding the DFU?

    I’d still like to figure out how to get the CPU time down…

    Thanks again!




    That’s a hint for the CPU problem. I had the same issue. The Makefile compiles a debug version by default and you need the release version.

Viewing 10 posts - 16 through 25 (of 25 total)

You must be logged in to reply to this topic.

Latest News


Follow us on Twitter