Could not find a connected DFU device

Home Forums OWL OwlWare Could not find a connected DFU device

This topic contains 17 replies, has 7 voices, and was last updated by  Martin Klang 2 years, 3 months ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #1525

    d3b5s3r
    Participant

    I am using Windows 7 and I am trying to update my OWL. I connects to the OwlNest and I can get and save the settings from and to it. However when I try and update it to the latest firmware at about 16% I get a message saying:

    “Could not find a connected DFU device”

    I do see the device in the Device Manager as:

    “STM Device in DFU Mode”

    GENERAL
    Device Type: Universal Serial Bus controllers
    Manufacturer: STMicroelectronics
    Location: Port_#0001.Hub_#0005
    Device Status: This Device is working properly

    DRIVER
    Driver Provider: STMicroelectronics
    Driver Date: 7/5/2012
    Driver: 3.0.4.0
    Digital Signer: Microsoft Windows Hardware Compatibility Publisher

    #1526

    giom
    Keymaster

    Hi, can you tell me what devices you see in owlnest / application settings tab ?
    I will get access to my windows 7 computer on wednesday and will look into that.
    Thanks

    #1527

    d3b5s3r
    Participant

    Application Settings: (selected option in square brackets)
    Audio Device Type: [Windows Audio] / Direct Sound
    Output: OUT (3-DUO CAPTURE EX) / Digital Audio (S/PDIF) (High Definition Audio Device) / [<< none >>]
    Active MIDI Inputs: [OWL FS] / 3-DUO-CAPTURE EX
    MIDI Output: [OWL FS]

    After I try and run the update the pedal goes in DFU Mode (I hear the USB lose and reconnect it). When I open and close OWL Nest the OWL FS Option disappears. If I reset the OWL Pedal OWLNest finds it again.

    • This reply was modified 3 years, 7 months ago by  d3b5s3r.
    #1529

    d3b5s3r
    Participant

    Just tried it on my wife’s laptop running Windows 8 and I get the same behavior and message.

    #1536

    giom
    Keymaster

    It might be a windows driver issue. the team is looking into it.

    #1537

    latzenpratz
    Participant

    I have the same problem with win8.1

    #1538

    pheripheral
    Participant

    Hi,

    I also am having these same symptoms when trying to update firmware
    same usb dropout noises and gets to 16% and shows the Could not find a connected DFU device message

    on windows vista (i know i know)

    #1539

    giom
    Keymaster

    OK, reproduced the problem on Windows 7.
    We found a solution today (update the driver for the Owl in DFU mode) I’ll edit the wiki and post a link in this thread asap (hopefully today).

    #1540

    giom
    Keymaster

    Here is the procedure we suggest you to follow:
    http://hoxtonowl.com/wiki/Windows_drivers

    Let us know if this works for you, with your Windows OS version. Thanks!

    #1541

    pheripheral
    Participant

    Windows Vista test Update!

    the procedure worked and I have now sucessfully installed latest firmware via OwlNest.

    Slight difference in how the device appears in Zadig:
    Device listed as “STM Device in DFU Mode”
    and the driver on the left listed as
    STTub30 (v3.0.1.0) until its been updated.
    Others parts are the same though
    USB ID 0483 DF11
    WCID X

    Thanks for the quick response and fix.

    #1542

    d3b5s3r
    Participant

    I was able to update as well. Played around a little bit with some of the patches, tried the synthesizer patch. It worked for a few minutes but then it stopped recognizing the notes I was playing, the delay patch I had loaded sounded distorted as well. I tried resetting but all the patches sounded distorted. I will try again tonight. I might have to change the output I put it on my Pedal Power (100 ma vs 250 ma), which leads me to my next question. What is the minimum amount of mA needed to run the Owl reliably?

    #1545

    giom
    Keymaster

    For power requirements, and also adjusting input sensitivity, please refer to the
    Getting Started page.

    • This reply was modified 3 years, 6 months ago by  giom.
    #2030

    oberdada
    Participant

    I’m duplicating this error on linux (Fedora 20) with the message “could not find a connected DFU device” at 16 %. What would the linux workaround be?

    #2031

    stereosmiles
    Participant

    Hi, I’m very new to all of this stuff. I got a second-hand OWL from eBay recently, managed to plug it in, but then I attempted to update the firmware and it appears to have done a similar thing to the above. I’ve followed the instructions for the Zadig tool, but the device appears as “OWL FS (interface 0)” and not STM32 BOOTLOADER (which doesn’t appear in the list) – is that a problem? I presumed it wasn’t and updated the USB driver, which went ok. Then attempted to update the firmware but hits 16% and states the “Could not find a connected DFU device” message. Not really sure how to proceed. I think I’ve launched non-DFU mode (the LED flashes red once as per the instructions at least). Power cycling where the LED flashes red three times doesn’t seem to happen.

    I’ve opened the box, and it’s a rev004 unit, but hoping I don’t need to use the wires!!!

    #2032

    Martin Klang
    Keymaster

    @oberdada: on Linux, you usually have to run OwlNest as root (sudo) for DFU access to work.
    Upgrade to the latest v10, swap to using OwlNest instead of OwlControl, and then, with any luck, you’ll never have to DFU again!

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.


Latest News

Links

Follow us on Twitter